User talk:Ameisenigel

From Wikifunctions
Logo of Wikifunctions

Welcome to Wikifunctions, Ameisenigel!

Wikifunctions is an open repository of code functions that anyone can use and contribute to!

Do you need some help getting started? Here are some pages you can familiarize yourself with:

  • Introduction – An introduction to the project.
  • Community portal – The portal for community members.
  • Contents – The main help page for editing and using the site.
  • Glossary – Definitions of frequently used terms.
  • FAQ – Frequently asked questions.
  • Project chat – Discussions about the project.

Please remember to sign your messages on talk pages by typing four tildes (~~~~); this will automatically insert your username and the date.

If you have any questions, don't hesitate to ask on Project chat. Once again, welcome, and I hope you quickly feel comfortable here, and become an active contributor to Wikifunctions.

Best regards! VIGNERON (talk) 19:29, 21 August 2023 (UTC)[reply]

Reverting

Hello, I see you're sysop that is active right now. can you revert my edit special:diff/41779? thank you. Xnet1234 (talk) 21:13, 22 August 2023 (UTC)[reply]

No problem, done --Ameisenigel (talk) 21:15, 22 August 2023 (UTC)[reply]

bot flag

Hi, sorry to bother you! Am I correct that you were responsible for adding this account to the bot user group, per my request? It appears that went correctly, per the list of bots.

However, there are two little weird issues. One is that I can't find any record of the user group being given out. I'd expect it to be in this log, like for FuzzyBot? The second is that I haven't managed to edit with the bot flag. Of course, that might very well/likely be user error or an error in my tool/configuration. I just thought it was weird in combination with the lack of a log; do you think that's significant or a red herring? When I tried to edit with the bot flag set, I got the following MediaWiki API error: apierror-assertbotfailed.

To be complete, I checked the userinfo endpoint, which reported that I have the bot right and that I am in the bot group. Do you have any ideas? --AzBot (talk) 11:21, 4 April 2024 (UTC)[reply]

In the early beginning of the project staff has handled all user rights. This has been handed over to the community some time ago. Since we do not have any local bureaucrats we need some help of the stewards for advanced rights. You can find the log on Meta: [1]. Since I am not a bot maintainer I am not sure what you have to do to edit with the bot flag. Maybe mw:API:Assert provides some help? --Ameisenigel (talk) 12:28, 4 April 2024 (UTC)[reply]
Thanks for the info and for allowing me to stop chasing that red herring! Given that the two were unrelated, I tracked it down to a missing grant on my bot password and a bug in the library I was using. --AzBot (talk) 14:31, 4 April 2024 (UTC)[reply]
To add to my confusion, "bot flags" only seem to show up on Special:RecentChanges, not in the regular page history. So that threw me for a bit as well... --AzBot (talk) 14:37, 4 April 2024 (UTC)[reply]